Autoclave Repair Tips

Autoclave Repair Made Simple

Welcome! 

Need help repairing your autoclave?

Simply post your autoclave repair questions here.  Give us as much detail as you can about the problems you are having.  And please include the make and model of your autoclave (Midmark M9, Pelton Crane OCM, Tuttanuer 2540M, etc)

Have any autoclave repair tips?  Please post them!

This forum has been created and is maintained by AllClaveParts.   Visit us.  We have many Troubleshooting Guides and Factory Service Manuals for your use.  And Best of All, they are FREE

Be Sociable, Share!

2 Responses to “”

  1. Karen Swanson says:

    I have an OMNI-Clave sterilizer and the heat light is not coming on nor is it sterilizing (heating). I read about fuses, does this sterilizer have a fuse and is this where I should start? Thanks for your help.

  2. Wally Wally says:

    Hi Karen

    Very few of the Pelton Crane OCM and OCR Autoclaves have fuses.

    From your description, it sounds like you have either a faulty overheat thermostat of a bad heating element.

    You will need to remove the cabinet to get to both items.

    The overheat thermostat is located towards the front and bottom of the chamber and looks like points off an old car
    Overheat thermostat
    You can test it for continuity…if it is continuous, then it is most likely okay. You can also test it by “jumpering” it out of the system (bypass it). Then if the unit works as normal, you will know the overheat thermostat is bad and needs to be replaced

    To be able to tell you how to test the heating elements, I will need to know whether you have an OCM, or an OCR. If you have 3 screws along the bottom sides holding the cabinet to the base, you have an OCM. If there are 4, then you have an OCR

    Let me know and we can move on as needed

Leave a Reply

You must be logged in to post a comment.

Get our latest updates

Subscribe Via A Feed Reader

  • Sections
  • Latest
  • Comments
  • Tags

Archives