Autoclave Repair Tips

Autoclave Repair Made Simple

Tuttnauer EZ10 High Temp Error

Error Message “HIGH TEMP

When your Tuttnauer EZ10 Autoclave aborts the cycle, the Cycle Fail light comes on, and the display reads HIGH TEMP…..Here is what you need to know

To help you locate the problem, the first thing you need to do is to determine when this is happening. Is it failing during the Sterilization Phase Cycle or just before the Heat Phase starts? If the “HIGH TEMP” error is occurring…….

During The Sterilization Cycle

The cycle is aborted and the Cycle Fail indicator lights up and the Display reads “HIGH TEMP” on your Tuttnauer EZ10 autoclave during the Sterilization Phase of the Cycle if the temperature rises 9°F (5°C) above the required sterilization temperature during the Sterilization phase of the cycle.

Possible causes for this message on the Tuttnauer EZ10 Autoclave are: The Heating Elements are remaining on instead of cycling on and off

Check Your Tuttnauer EZ10 Autoclave For

  • A Shorted Solid State Relay (if found defective, replacement is required)
  • Shorted Heating Element (if found defective, replacement will be required)
  • Other Short Circuit (check all wiring on your Tuttnauer EZ10 Autoclave for loose connections or breaks….tighten loose connections and replace any damaged wire)

If the “HIGH TEMP” is being displayed……

Before Or During The Heat Phase

If the error is occurring before the Heat UP Phase Starts or any time during the Heat Up Phase, it indicates a defective Temperature Sensor and the Temperature Sensor on your Tuttnauer EZ10 Autoclave will need to be replaced

“Tuttnauer EZ10 Autoclave Repair Made Simple™”
Be Sociable, Share!

Leave a Reply

You must be logged in to post a comment.

Get our latest updates

Subscribe Via A Feed Reader

  • Sections
  • Latest
  • Comments
  • Tags

Archives